Announcement

Collapse
No announcement yet.

SMTP Authentication Error

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • SMTP Authentication Error

    Hello,

    We've been using uberSVN for some time now, and overall we're pleased with it.

    However, one bit of functionality lost is the SMTP e-mail notifications. I've tried for many hours to get this to work, but I'm lost.

    Here's what happens:

    - I configure the e-mail server with the correct information.
    - I hit the "Test" button and receive the following:

    "Unable to send email: No authentication mechansims supported by both server and client"

    When I check the logs, all I see is essentially the same message. Is there anything I can do to try and track this down?

    Thanks,

    Sam Ferrise
    sferrise@deloitte.com

  • #2
    Hi there,

    I'm glad you're pleased with uberSVN so far, let's see if we can get email notifications working for you too.

    Does your mail server require SSL/TLS?

    Comment


    • #3
      I do not believe so. However, I do have it configured with the certificates in the keystore if necessary.

      Comment


      • #4
        Can you tell us what settings you have configured in uberSVN (with any sensitive information sanitised obviously)?

        Comment


        • #5
          has this been sorted out? We have just changed our email from exchange to mine sweeper and no longer need authentication, but I can't remove it

          Comment


          • #6
            Hi,

            Any chance you could post a screencap of your email settings page please (with any sensitive info blanked out)? It *should* be a matter of just choosing the 'No' radio button in the authentication settings at the bottom.

            EDIT: You should leave the current authentication details in when you select the 'no' option, if you delete them it doesn't seem to want to save the settings unfortunately. Perhaps that's what happened in your case?
            Last edited by orbrey; 01-06-2015, 04:26 PM.

            Comment


            • #7
              Hi
              I've taken them out / left them in, tried everything but still get the same error
              ubersvnError.jpg
              ubersvnError2.PNG

              Comment


              • #8
                Couple of things (and sorry for possibly daft questions) - can you send mails via the minesweeper server without auth using other programs? If so, is the server possibly expecting a server -> server connection request and being rejected as ubersvn is trying to connect as a client (so client -> server) instead?

                Comment


                • #9
                  yes the minesweeper works in other programs.
                  we are using client > server connection
                  Is there a congif file that I can edit to remove the userid / password as it seem to retain this even though I've set it to no authentification?

                  Comment


                  • #10
                    Hello,

                    I've had a look into this and have found that the following steps allow you to remove the username/password:

                    1. Stop UberSVN
                    2. Open the file /path/to/uberSVN/ubersvn-db/ubersvn-db.script (it would be worth taking a backup of this file first)
                    3. Look for the following lines: (you won't see an exact match as the timestamps will be different)
                    Code:
                    INSERT INTO CONFIGURATION VALUES(18,'2014-06-26 17:54:47.051000000','2015-01-13 11:49:50.802000000','SMTP Username',NULL,3,'<username>')
                    INSERT INTO CONFIGURATION VALUES(19,'2014-06-26 17:54:47.051000000','2015-01-13 11:51:09.006000000','SMTP Password',NULL,3,'<password>')
                    And change to:
                    Code:
                    INSERT INTO CONFIGURATION VALUES(18,'2014-06-26 17:54:47.051000000','2015-01-13 11:49:50.802000000','SMTP Username',NULL,3,'')
                    INSERT INTO CONFIGURATION VALUES(19,'2014-06-26 17:54:47.051000000','2015-01-13 11:51:09.006000000','SMTP Password',NULL,3,'')
                    4. Ensure that 'SMTP Authentication Enabled' is set to 'false' and not 'true'
                    5. Save the changes
                    6. Start UberSVN

                    Comment


                    • #11
                      I've used the above to remove the userid / password. the authentification is false but I still get the same as the screen shots previously posted.
                      Any further ideas?

                      Comment


                      • #12
                        Is that the same after a reboot as well? Not sure it'll make a difference but it often does.

                        Comment


                        • #13
                          rebooted over night - still doesn't work I'm afraid

                          Comment


                          • #14
                            Might be worth testing a fresh UberSVN install in a VM to see if the config works out of the box? If so, perhaps an uninstall of UberSVN with a quick check in the registry for any remaining keys then a reinstall might sort it?

                            Comment


                            • #15
                              We'll give up on this thanks. Re-installing is more trouble than it's worth!! We'll put up with not being able to use the email functionality.

                              Comment

                              Working...
                              X