Announcement

Collapse
No announcement yet.

Impossible to activate LDAP authenticate

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Impossible to activate LDAP authenticate

    Hello,

    I have a problem with my ubersvn on Windows 2008 Server. I import new users from my LDAP Active Directory and I affect all admin privileges for one imported user but when I try to activate the LDAP authentification, I have this message :

    No existing sysadmins could be retrieved from any LDAP Location, a user with system admin privileges that can authenticate against LDAP must be defined before LDAP login can be enabled

    I don't understand why and I have no errors in my logs.

    Please can you help me.

  • #2
    And I have the last version of ubersvn : 12.10

    Comment


    • #3
      Originally posted by Na00
      But i want to tell that this www.svnforum.org is extremely helpful, Thanks for taking your time to write this. regards
      Thanks but I have already search in this forum and I have not found my answer. That's why I post this question.

      Comment


      • #4
        When my error appears, I have this message in the ubersvn.log :

        [30 oct. 2012 11:32:33] INFO (?) - Naming Exception

        I don't know if it can help ...

        Comment


        • #5
          Hi
          You have to set an LDAP account as admin before you can change logon via LDAP

          Cheers
          Thobbe

          Comment


          • #6
            Originally posted by thobbe View Post
            Hi
            You have to set an LDAP account as admin before you can change logon via LDAP

            Cheers
            Thobbe
            Hi thobbe,
            Yes I have. It's not the first time I configure an uberSVN with LDAP connection and I don't understand why It doesn't work...

            Comment


            • #7
              Originally posted by aducousso View Post
              Hi thobbe,
              Yes I have. It's not the first time I configure an uberSVN with LDAP connection and I don't understand why It doesn't work...
              I seem to be having the same problem.
              • Have LDAP configured
              • Imported users from LDAP
              • Marked myself as System Admin, Global Team Admin, Global Repository Admin, uberAQpps user
              • Go to LDAP Locations and click Use LDAP for uber login authentication

              Receive error:
              No existing sysadmins could be retrieved from any LDAP Location, a user with system admin privileges that can authenticate against LDAP must be defined before LDAP login can be enabled.

              When trying to activate LDAP, I notice in the ubersvn.log, I am getting:
              [01 Nov 2012 20:27:47] INFO (?) - Missing 'equals'
              [01 Nov 2012 20:27:47] INFO (?) - Missing 'equals'

              Comment


              • #8
                Which LDAP server are you using? Does the username of the admin user correlate to the uid of the user in LDAP?

                Comment


                • #9
                  I use an Active Directory LDAP.

                  Yes, the username of my admin user in uberSVN is the same as sAMAccountName (=uid) in my AD.

                  Comment


                  • #10
                    What's the username you're using as admin? Also, how many LDAP authorities do you have configured?

                    Comment


                    • #11
                      One additional thing, can you post the LDAP query you're using please?

                      Comment


                      • #12
                        I use a username imported from my Active Directory as admin : aducoussobal

                        I have only one LDAP authority configured.

                        This is my LDAP query :
                        ldap://micro.pj.fr:389/dc=micro,dc=pj,dc=fr?sAMAccountName?sub?(|(&(objec tClass=user)(objectCategory=person)(|(extensionAtt ribute2=D ADNET)(extensionAttribute2=D SYSTEMES D INFORMATIONS)(extensionAttribute2=D TECHNIQUE)))(&(objectClass=user)(objectCategory=pe rson)(mailNickname=*)(msExchHomeServerName=*)(prox yAddresses=*.externe@pagesjaunes.fr)(|(extensionAt tribute2=DSI*)(extensionAttribute2=*Information*)) (!(name=SystemMailbox{*))(!(name=CAS_{*))))

                        This query works well in my ldapbrowser and to import users in ubersvn.
                        Last edited by aducousso; 11-05-2012, 12:44 PM.

                        Comment


                        • #13
                          Hi aducousso,

                          I notice a lot of spaces in your query string e.g. 'objec tClass=user' should this not be objectClass=user? There are several spaces in the query that I think should not be there. Can you remove the spaces in question and retry? We are currently working on updating Uber to detect this sort of problem.

                          Cheers,
                          Trev
                          Last edited by Trev Thompson; 11-05-2012, 07:46 PM.

                          Comment


                          • #14
                            Originally posted by Mand View Post
                            Which LDAP server are you using? Does the username of the admin user correlate to the uid of the user in LDAP?
                            Sorry for the delay. I don't have direct access to the server, but it is MS AD. I was able to import users from my security group into UberSVN, and as a local admin user, I made my imported LDAP ID admin. I tried to activate the LDAP authentication and saw the errors I posted previously.

                            Comment


                            • #15
                              Hi DaveOfTheDogs,

                              Can you upgrade to Uber 12-11? This update has improved feedback to the user regarding LDAP and will notify you of any problems with LDAP config.

                              Cheers,
                              Trev

                              Comment

                              Working...
                              X