Announcement

Collapse
No announcement yet.

Different ports for different interfaces

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Different ports for different interfaces

    I've got the repositories set up to use port 80, for our private network. Everything is working fine for this. However, now I'd like to enable the second interface on the machine, which goes to the rest of the LAN. For connections from this interface, I'd like them to use 443 (but the internal ones still using 80). Before, we just did this in apache - bound to the internal IP in httpd.conf, and to the external IP in ssl.conf. I'm not sure how to integrate this with UberSVN, though. Can I do the same thing directly in the conf files? Will that conflict with anything UberSVN is doing?

    Thanks!

  • #2
    Originally posted by teleute View Post
    I've got the repositories set up to use port 80, for our private network. Everything is working fine for this. However, now I'd like to enable the second interface on the machine, which goes to the rest of the LAN. For connections from this interface, I'd like them to use 443 (but the internal ones still using 80). Before, we just did this in apache - bound to the internal IP in httpd.conf, and to the external IP in ssl.conf. I'm not sure how to integrate this with UberSVN, though. Can I do the same thing directly in the conf files? Will that conflict with anything UberSVN is doing?

    Thanks!
    In case anyone's curious, I did get this to work, and it seems to be just fine (no conflicts with normal operation that I can see). In the GUI, under Subversion Server, I selected 80 as the port, and the eth0 IP for "Bind IP". Then, I manually edited <uberSVN path>/conf/extra/httpd-ssl.conf to make sure that it had all the correct cert info (paths, etc...) and then put in the line "Listen <eth1 IP>:443". Then in the main httpd.conf (can be done manually or in the GUI, either way) I uncommented the line to include that httpd-ssl.conf file. Restarted and it's all working as desired, so far.

    Comment

    Working...
    X