Announcement

Collapse
No announcement yet.

HELP: uberSVN can't load config page ....can't establish a connection to the server

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • HELP: uberSVN can't load config page ....can't establish a connection to the server

    Hi all,

    I have installed uberSVN locally on my Windows7 machine but getting an error when trying to view the browser config page. I have followed the instructions from http://docs.ubersvn.com/v1.0/install.html#I13 ...but at step 7 when you have to click the button to "continue the installation of uverSVN" which presumably is the config page ...firefox launches and attempts to open "http://127.0.0.1:9890/ubersvn" however I get the below error? From what I understand I don't need to install anything else for this to work ...the uberSVN binary should just work right out of the box right?

    "Firefox can't establish a connection to the server at 127.0.0.1:9890"

    Can anyone suggest what I am missing? I am attempting to "launch uberSVN" from the same machine it was installed to.

    I tried to debug myself by doing the following (which I found some people tried):
    - manually create an application rule in my AntiVirus app (BitDefender) for httpd.exe. When I look at Network activity I can see that the port is definitely open - just no data going through it.
    - Rebooted
    - tried using IE but same issue (Whoops! The page could not be found. Try giving it another chance below.)
    - made sure there was nothing odd with my hosts file (C:\Windows\System32\drivers\etc) ...the contents are just the default that comes with a Win7 install
    - I connected ssh to my hosting provider via putty just to make sure I wasn't having larger connectivity issues but everything appears fine so it seems local to the application and me missing something ...a setting perhaps?

    I'm running Firefox 13 and the latest version of ubersvn btw...

    Any help/suggestions would be greatly appreciated. Thanks.

    Cheers
    Nick.
    Last edited by niic; 06-11-2012, 08:29 PM.

  • #2
    when you do ifconfig in terminal, is this the same ip address which you are using in the address bar ?
    if not and even if so, it could be worth while configuring your ip address to the ubersvn programme as follow
    $ sudo gedit /opt/ubersvn/tomcat/conf/server.xml (there is more in the file then as shown below but below is what is important)
    port="8080"
    protocol="HTTP/1.1"
    address="127.0.0.1"
    connectionTimeout="20000"
    redirectPort="8443"
    your port numbers may be different and if this is the case, dont panic, where it says address="127.0.0.1", change that number to your ip address, if that line isnt shown in the server.xml then you will have to personally type in the line, after you have done all this click on save and close the text file down,
    now you need to do this in the terminal,
    $ cd /opt/ubersvn/bin/
    $ sudo ./ubersvncontrol stop
    $ sudo ./ubersvncontrol start
    now go back to you internet programme and type in your information, example of above would be http://127.0.0.1:8443/ubersvn

    Comment


    • #3
      i have repaired this problem on ubuntu so i may be able to help you also repair this on windows 7 without much trouble
      when i get home tonight i will install ubersvn on my copy of windows 7 and i will have a look into making you a guide to enable you to reapir this problem in windows 7
      that way i will be able to locate all the correct files and work out all the correct commands to make the guide allot more clear
      i will try and have this done by tonight
      Last edited by squeekjjy; 07-09-2012, 12:12 PM. Reason: wrong information

      Comment


      • #4
        http://docs.ubersvn.com/v1.0/admin.html
        do what it says on the website on the windows section, stop ubersvn then start and it should be bk up and running, if not we might need to just tweak a file later on but for now see if this cures your issue

        Comment


        • #5
          Hi niic,

          This may sound simple but are you attempting to connect on that URL via the same desktop on the box where uberSVN is installed, or via a different machine? If the latter, it won't work because the loopback address is stated, which will only ever be relevant if you're on the same machine. What I'd do first is try to connect using the actual IP address. You can get this by opening a Command Prompt and using the 'ipconfig' command.

          If that doesn't work, make sure the uberSVN services are running. Start > Computer > Right Click > Manage > Expand Services and Applications > Services > Check that you have two uberSVN-based services and that they're both running. They'll start with WANdisco, so scroll down to close to the bottom.

          If they are, make sure that UAC and the Firewall isn't preventing anything. Windows 7 is more secure than previously released Windows-based desktop OSs so its possible there's something blocking us from starting.

          Give those a try and let us know how you get on.


          Thanks

          Wayne

          Comment

          Working...
          X