Announcement

Collapse
No announcement yet.

uberSVN LDAP Connection established, Repository Configuration not possibe

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • uberSVN LDAP Connection established, Repository Configuration not possibe

    Hello together,

    I've tried to establish a LDAP Connection. With the Help of a explanation here I've managed it.

    There was no error after a test connection. Still I'm now stuck.

    After the successful test-connection I've wanted to configure the Repository for LDAP:
    • -> Repositories -> [Test Repository] -> Authentication
    • Change from "uberSVN Internally Managed" to "LDAP / Active Directory Authentication"
    • Load the working Default Setting
    • Save & Restart Server


    So after this I've followed the explanation on the mentioned Topic:
    • -> Repositories -> [Test Repository] -> Permissions
    • Within "uberSVN Internally Managed" I've wrote the Username and clicked ADD


    Now I'm stuck there.
    If the LDAP Setting seems correct: I've add User, a Refresh of the Page happen. But nothing change.
    If the LDAP Settings are "wrong" (broken): I've try to add the user and the regular "No Team or User Found"

    And trying to Browse the Repository will end in "Authentication failed".

    So what I am doing wrong?

    About the LDAP Setting:
    Our System-Admin made following AD Structur:
    [Server]
    -[OU=Company]
    --[OU=Users]
    ---[OU=Location 1]
    ---[OU=Location 2]
    -[CN=Users](Windows defaults)

    In our team we're currently are 5 people using SVN, and 4 are in Location1 and 1 is in Location 2
    The Settings looks like (Without the []):
    LDAP URL: ldap://[Server]:389/OU=[Users],DC=[company];DC=local?sAMAccountName?sub?(objectClass=*)
    [i]also tried: ldap://[Server]:389/OU=[Users],OU=[Location 1],OU=[Location 2],DC=[company];DC=local?sAMAccountName?sub?(objectClass=*)
    AuthBasicProvider: ldap
    AuthzLDAPAuthoritative: Yes
    AuthLDAPGroupAttribute: <empty>
    AuthLDAPGroupAttributeIsDNS: Yes
    Require: valid-user
    Anymous Bind: No (Connection Settings of Bind DN/Password working. Tested with several LDAP Solutions)

    Thank you in advance for your help.

  • #2
    I think I understand the situation.

    The LDAP connection in uberSVN is currently used to run the authentication and doesn't support importing (or adding) users directly off the LDAP/AD server. It is necessary for you to export those users into a csv file from the Location1 and Location2 groups you have setup and then import them back into uberSVN, or it is necessary to add each user one at a time under the Users tab.

    There's a write up on how to create the csv file using a tool called LDAP Explorer but you could use any tool (csvde for example) to create the text file in the uber format which is "username, full name, email, password" (for ldap users you just enter a dummy value for password).

    http://support.wandisco.com/index.ph...barticleid=330

    Once they are created the LDAP settings you entered are used to authenticate the users, so the dummy password value isn't used.

    Comment


    • #3
      Hi Telaran,

      From your post I'm not 100% sure about the problem you're having. If I can just clarify:

      - You are setting the 'Test Repository' repository to use LDAP, and entering the Apache configuration options you believe are correct (and I understand you have tested your string in a query browser of some sort to check it returns the correct results?).

      - User authentication is failing when accessing the repo, although the test connection button works (This only tests the bind onto the AD server is valid, not that your LDAP query string is correct).

      My first question would be if you can see the authentication issues in the Apache error log (available from the viewer in the admin section of the user interface, or stored in the /opt/ubersvn/data/logs directory )?

      Best Wishes,

      Ian

      Comment


      • #4
        Hi Lan,

        I face similar issue as mentioned by Telaran. I get authentication failed error when I try to access repositories.
        I checked the error_log and I see the authentication issue mentioned there.
        Can you please suggest a way out?

        Thanks

        Comment


        • #5
          I have the same problem. Does anyone has a correct setup for LDAP?

          THX

          Comment

          Working...
          X