Announcement

Collapse

Announcement

These forums are now closed to new posts.

SmartSVN users who require support are advised to use one of the options provided by SmartSVN GmbH here:
http://www.smartsvn.com/contact
See more
See less

SmartSVN 8.6 64bit doesn't ship with 64bit JRE

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • SmartSVN 8.6 64bit doesn't ship with 64bit JRE

    It seems the 64bit installer ships with the 32bit JRE, which is rather pointless as I can't specify heap sizes >1.5GB. Going to the included JRE and running "java -d64 -Xmx2000m" exits with
    Code:
    Error: This Java instance does not support a 64-bit JVM.
    Please install the desired version.
    Dropping the "-d64" results in the rather predictable
    Code:
    Error occurred during initialization of VM
    Could not reserve enough space for object heap
    Which mirrors what SmartSVN itself reports when trying to start it with the same option.

    Does this mean the 64bit SmartSVN requires one to manually install and maintain a JRE? If so, why even include a JRE?

  • #2
    Ok, replacing the private jre with the official 64bit 1.7u51 jre doesn't work. Complains with
    Code:
    The JVM found at ..\jre is damaged. Please reinstall or define SMARTSVN_JAVA_HOME to point to an installed 32-bit JDK or JRE.
    So what exactly is 64bit about the 64bit SmartSVN? The shell extension?

    Comment


    • #3
      Google wasn't very friendly so didn't find http://www.wandisco.com/svnforum/thr...64-bit-Problem which confirms that there's nothing 64bit about the 64bit release. So the bug is then that the release is labeled 64bit when it isn't.

      Comment


      • #4
        Hi,

        Yes, the program integrates with the 64 bit explorer - though from asking about this it sounds like it could be a memory issue? You could try increasing the heap size to 1.6GB to help with using annotate, or if it's a particularly large repository and/or has a lot of revisions you could also try limiting the depth of revisions you're searching if that's feasible?

        Comment


        • #5
          Originally posted by orbrey View Post
          though from asking about this it sounds like it could be a memory issue? You could try increasing the heap size to 1.6GB to help with using annotate
          No, I can't even raise it that much without it complaining. I haven't found the exact limit but "-Xmx1295m" works and "-Xmx1300m" does not. I've got more than enough free memory (ie a lot more than 1.3GB), and I'm running Win7 x64. Though I estimate I'd need closer to 2-2.5GB for the heaviest annotate operation, based on memory usage since start of operation vs progress bar when it runs out of memory.

          Sadly limiting the revisions to annotate frequently misses the information I'm after, so that's rarely an option. For now keeping a git repository in sync via git-svn seems to be the best approach for me. Git manages to annotate about two orders of magnitude faster (less than a minute vs >30 minutes), and without the memory issues. Not exactly ideal though, when it works the SmartSVN annotate window is quite nice.

          Comment

          Working...
          X