No announcement yet.

VisualSVN Error Revision File lacks Trailing Newline

  • Filter
  • Time
  • Show
Clear All
new posts

  • VisualSVN Error Revision File lacks Trailing Newline

    We have VisualSVN version 2.1.3 installed on Windows 2003 server and all client machines are using tortoisesvn Client for commits and other svn operation. Everything was working fine till yesterday.
    Yesterday , I committed a revision number 22181 in the night and left the office and this is the last commit which happened since yesterday.
    When I tried to show log today or tried to update SVN, I got this error : Revision File Lacks Trailing Newline. Screenshot of Error attached with this post.
    And then i started researching and tried lots of things including the link below which comes as first result in google when I type the error description.

    Though this link says that this error occurs when svn commit size is more than 4 gb but the last commit which I did was of hardly 1 MB. I still performed the above steps mentioned in the post and after this i was able to do show log into the repository which is a good sign but then i got another error when i tried to commit a file :

    Cannot move tempfile.2.tmp to txn-current : the disk structure is corrupted.

    Then I reverted the above changes as I took the backup in the beginning and researched more and as per above instruction, it gave me an idea that the problem is with the last revision which I committed yesterday. Then i tried svnadmin.exe using command line and used dump command to make a dump file between revision 1-22180 but but was amazed to see that my server got hanged as maybe dump size which was getting created was more than the size of drive where I was saving the dump file. My motif behind dump was to dump all revisions except last that is 22181 and then create a new repository and load the dump file and that might solve the problem. And then I read that if we specify specific revisions in the dump command , it takes more space than the dump created of whole database. But if take dump of whole database then how do I remove last revision from complete dump file?
    If you want to know svnadmin command i ran then here it is :
    svnadmin.exe dump r 1-9 F:\svn-repo > C:\Tempdump.dmp
    Now I am trying to use verify command after posting this message.

    Please help me resolve this problem as I am tired now and tomorrow our staff wont be able to work without svn operations as it is critical. Our SVN repository size is nearly 35GB and I think if I have to use dump command then I will have to attach a USB harddisk in order to save dump file as the server drive which has maximum space is C drive with 48 GB space.

    I am not sure what the actual solution is. Please help and thank you reading everything.

    ThanksSVN Error.jpg

  • #2
    Hi there,

    If the fix on the page you linked to hasn't worked then dumping the repository and reloading it is definitely the way forward - there's some good information on how to do that here:

    It may well need an external drive to dump the file to if there's no way you can clear any space off the one the repository is on already - also if that's the only drive on the server and it's filling up then it'll be running out of page file space which (depending on how much memory the machine has) may be contributing to the slowdown.

    Hope that helps, good luck and I hope you get it working again.