Announcement

Collapse
No announcement yet.

What is this strange "H?\85?\C0?\84?\92" file?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • What is this strange "H?\85?\C0?\84?\92" file?

    I've recently moved to macOS 10.15 Catalina, and am trying to get svn going again. I gave up on building it from source (see my [URL="https://www.svnforum.org/forum/opensource-subversion-forums/general-setup-and-troubleshooting/81012-any-easy-way-to-get-svn-back-on-macos-10-15-catalina"]other thread[/URL] about that), and I installed it with homebrew. The installation appeared to be successful, in that it can report its version and do a checkout:

    [CODE]
    svn --version 16:52:29
    svn, version 1.14.0 (r1876290)
    compiled Jul 4 2020, 21:17:27 on x86_64-apple-darwin19.5.0

    Copyright (C) 2020 The Apache Software Foundation.
    This software consists of contributions made by many people;
    see the NOTICE file for more information.
    Subversion is open source software, see http://subversion.apache.org/

    The following repository access (RA) modules are available:

    * ra_svn : Module for accessing a repository using the svn network protocol.
    - with Cyrus SASL authentication
    - handles 'svn' scheme
    * ra_local : Module for accessing a repository on local disk.
    - handles 'file' scheme
    * ra_serf : Module for accessing a repository via WebDAV protocol using serf.
    - using serf 1.3.9 (compiled with 1.3.9)
    - handles 'http' scheme
    - handles 'https' scheme

    The following authentication credential caches are available:

    * Mac OS X Keychain
    [/CODE]

    ...but though the check out brings down the correct files, as viewed in Terminal, when I do a svn status, it either segfaults or shows the following strange results:

    [CODE]
    svn st
    ? H?\85?\C0?\84?\92
    ! PerformanceNotes.txt
    ! StateAndStorage.txt
    ! idealNetworkDesign.txt
    [/CODE]

    Those three files marked with "!" status are actually there. They are NOT deleted; they are on disk and contain the correct data. But svn thinks they've been deleted. And even stranger, it's listing this weird "H?\85?\C0?\84?\92" file, which does not exist. On larger repos, I see that same weird file on every directory that does not segfault. (I haven't yet detected any pattern as to which directories segfault, and which merely show these incorrect results.)

    I'd like to be clear that this is happening on a freshly checked out repo. So it can't be some sort of mismatch between the version of svn that created the working directory, and the svn that's doing a status check; it's the very same svn, one command after the other. I also tried uninstalling svn, clearing out everything I could think of that might be related, reinstalling, deleting the old working directory, and doing it all again. Same result.

    I've tried googling for this, but to no avail; either I'm the first person ever to run into this, or Google simply can't search for "H?\85?\C0?\84?\92".

    Any idea how to debug this?

  • #2
    The normal cause of such issues is the fact that MacOS is: 1. a case insensitive file system, 2. has some unique issues with UTF encodings.

    On a "real linux" check to see if you have any files with identical names when taking into account case insensitivity.
    Also, check that there are no UTF encoded file names in your repository.

    Comment


    • #3
      There are no identical file names (even ignoring case), and no non-ASCII filenames, either.

      macOS Catalina is more aggressive than I'm used to about file permissions; could that somehow be related? (Seems unlikely, since the process was able to write the files.)

      Comment


      • #4
        I assume that nobody turned on quotas, right?

        As for your assertion that there are non non-ASCII filenames, how did you determine this? To do it properly I'd do the same checkout onto a Linux system and then use "ls -R | od -c" and check the output carefully for non-ASCII.

        There's a good discussion about the UTF-8 issues with MacOS here: [url]https://users.subversion.apache.narkive.com/ByTvmOS4/encoding-problems-in-subversion-under-mac-os-x-hfs[/url]
        Perhaps that will help?

        Comment

        Working...
        X