No announcement yet.

TortoiseSVN - Can't enter new user credentials

  • Filter
  • Time
  • Show
Clear All
new posts

  • TortoiseSVN - Can't enter new user credentials

    Hi all!

    I am using TortoiseSVN on my Windows10 PC. The SVN server is running on a NAS.
    Everything was working without problems until I changed the password of my user on the SVN server.

    Now I am not able to connect to the repo. And I am not able to enter the new password, after the login failed.
    When I try to update my local repo I get the following error message:

    Unable to connect to repository at URL 'file://xxx/repo'
    Unable to open repository 'file://xxx/repo'
    Can't open file '\\nas\...\repo\format': Die Anforderung wird nicht untersützt.

    Does anyone know where the user credentials are hidden? How can I delete them?
    Or how can I enter new user credentials after the login failed?

    I searched in the internet and tried to find a solution for this problem.
    I read a lot of times that user credentails should be located here: C:\Users\xxx\AppData\Roaming\Subversion\auth
    But the folders in there are empty.

    Also reinstalling TortoiseSVN did not change the situation.

    Any ideas how I can solve this problem?

    Kind regards,

  • #2
    The "Die Anforderung wird nicht untersützt." translates to "The request is not supported." (google translate)
    That's strange. Are you sure that the NAS is still online? Can you bring up a browser and see the repository directory? What permissions does it have?

    Does a fresh checkout to a new disk location work or not?

    Have you found the TortoiseSVN command line svn command and tried to use that directly? Are you getting the same answer?

    Did you move the repository on the SAN?


    • #3
      Thanks for your answer.
      Yes, the NAS is still online. The repo is also available.
      Because we use a second pc with other user credentials and there everything is working fine.
      My user has read/write permessions for this repo on tha NAS. But as I mentioned before I changed the password for this user and since this time I am facing this problem.

      Also a checkout to an other location on my does not work. It looks like my pc is using the same user credentials. I am not able to enter a user name or a password.

      I have not tried to use the command line. I think the svn command was not available. Maybe I try to check this way...


      • #4
        How about changing the password back and seeing if it then works?

        Also, on your machine, use a windows explorer window and navigate to the NAS and see if you can create stuff there?


        • #5
          If I use the command line with username and password I can access the repo. Everything is ok then.

          It is a little bit strange. If I first connect my network on the NAS and after that try to use TortoiseSVN and check out the repo, then it also works. Then it seems to use the user credentials from the network drives also for the SVN. I don't know what is the reason. But that is the way it is working.


          • #6
            Glad to learn you've got a work-around (at least).