Announcement

Collapse
No announcement yet.

svn import ignores file without warning

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • svn import ignores file without warning

    Files are not imported into repository:

    I do have a subfolder "./lib" with files like "libtcmalloc.so.4.4.5" and so on.
    I found that those files are not existing in my working copy - thus I checked the repo "svn list " and this file is not in the repository.

    So I tried to import this file explicitely into the repo:
    svn import ./libtcmalloc.so.4.4.5 file:///icd_repos/icd_tools/clio/sos_7.04.p4_linux64/lib/libtcmalloc.so.4.4.5 -m "test"

    No error message is given - but still the file is not in the repository.
    It seems the import function ignores this file.

    Why is that ?

  • #2
    Wow, even if I copy the file into the working-copy and do "svn status", the file is not listet as new.
    I would expect to see the file as "? libtcmalloc.so.4.4.5"

    What is wrong with this file ?

    Once I renamed the file to "mylib" then it is not ignored by svn and is recognized by "svn status".

    I also can explicitley add the file via "svn add libtcmalloc.so.4.4.5" and "svn ci ..." then it is shown via "svn list ..repo.." in the repository.




    Last edited by HWe; 11-19-2018, 11:46 AM.

    Comment


    • #3
      Okay, I just learned, that the is a default ignore list by SVN, and that I can override it with the command option "--no-ignore".

      Now I am struggling to find where the list of ignored file extentions is stored. It not in the Home folder - there are all ignore lists commented out.

      Any idea where the global ignore list is located ?



      And another question comes up as well:
      I imported multi-GB data into the repository without the "--no-ignore" option - this means some files are missing in the repo.

      Now I want to import all the ignored files into the repo - how could I do that ?

      Importing folders to a repository can be done once only, right ?

      Last edited by HWe; 11-19-2018, 12:15 PM.

      Comment


      • #4
        What version of Subversion are you using?

        In any case, here's a great bit of learning: [url]https://stackoverflow.com/questions/2694900/is-there-a-concept-of-global-ignores-in-svn[/url]

        Comment


        • #5
          Using SVN 1.7.14.
          Yes, I found that link - from what I learned there, was that since version 1.8 it is possible to set repository dependent ignore lists.

          But as I am using version 1.7, and in my ~./.subversion/config all entries in [miscellany] are commented (not activ) I assume. See here the file content:

          [miscellany]
          ### Set global-ignores to a set of whitespace-delimited globs
          ### which Subversion will ignore in its 'status' output, and
          ### while importing or adding files and directories.
          ### '*' matches leading dots, e.g. '*.rej' matches '.foo.rej'.
          # global-ignores = *.o *.lo *.la *.al .libs *.so *.so.[0-9]* *.a *.pyc *.pyo
          # *.rej *~ #*# .#* .*.swp .DS_Store
          #

          The "#" means comment here, right ?

          I am wondering where the default ignores are defined.
          Is there a global ignore list under /usr or other subdir ?

          Comment


          • #6
            You might want to check the directories, down from the root of the repository, looking for a property called "svn:global-ignores" (not sure when that was included in the implementation but it is marked as "inheritable" meaning that all directories below where the setting is placed inherit it from their ancestor directory (parent, grandparent, etc.).

            Compare that with "svn:ignore" which is not inheritable (which you should also search for).

            Finally, the commented out lines in your ~/.subversion/config file are, exactly, the default global ignores. If you comment those lines out the behavior will not change and you can consider them documentation of the default. So if you want them changed then you should uncomment out those lines and make changes as needed.

            Comment


            • #7
              From
              [url]http://svnbook.red-bean.com/en/1.7/svn.advanced.confarea.html[/url]

              I learned that the default setting of svn:global-ignores is
              *.o *.lo *.la *.al .libs *.so *.so.[0-9]* *.a *.pyc *.pyo *.rej *~ #*# .#* .*.swp .DS_Store

              There is no file where this ist set, but one can change this default values set per user via "~./subversion/config". For example, to allow all files, do
              global-ignore=

              This might not be a wise decision, because this "global" change applies to all repositories/working copies accessed by this user.

              If one wants to have only one specific repo/working-copy to allow all data, and the other repos/working-copies shall use the svn:global-ignores - this is not possible in version <1.8.

              Since version 1.8 repository-path specific svn:global-ignores can be set.

              [SOLVED]





              Comment

              Working...
              X