Announcement

Collapse
No announcement yet.

Unexpected request for authentication

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Unexpected request for authentication

    A few months back I switched my primary home development platform from an older Windows 7 based system to a new Linux (Mint) system and have SVN version 1.9.3 installed. I learned how to move the repositories from the old system to the new one and was able to keep my project revision histories. For the current project I'm working on (transferred from the old system) I can checkin files with no problems. The other day I ran a program I wrote sometime back that exports a specific version of one of the files in that repository. It failed and, as I dug into things, I found that trying to export the file manually from the command line, I'm now asked for a password. The svn export command first prints a message that says "Authentication realm: ..." followed by a prompt for the
    password. I've never seen anything like this under Windows or on any of the new repositories I've created under Linux. I installed SmartSVN and found that I could save off a copy of any version of a file from the project repository but, other than verifying that the repository is healthy, this doesn't help as I need to access the file programatically. Reading the docs I learned about the
    .subversion/auth directory in my home path, which includes four subdirectories like svn.simple. etc., but all four are empty. Any tips on how to remove the request for a password?

  • #2
    You didn't say how you've setup to access your repos? Apache (http/s) or svnserve? The correct answer depends on which. If Apache then you'll need to check out how you have configured Apache. If svnserve then check what options it is getting launched with and, from there, which config files might be in play (normally the repository's configuration so "<repoPath>/conf/svnserve.conf").

    Just FYI: on Windows your password is stored securely via encryption - whereas on Linux it is NOT stored securely so most use a key-ring.

    Comment


    • #3
      Thank you Doug. In the past year and a half I've had two problems I wasn't able to solve on my own and you've now solved both of them. To answer your question, the repository was configured with svnserve. Your mention of "<repoPath>/conf/svnserve.conf" provided the hint I needed. I compared the svnserve.conf from a repository where everything was working fine against the svnserve.conf of the project respository where I was having problems. In the one with no problems, the lines "anon-access = read", "anon-acces = write" and "password-db = password" were all commented out but in the project repo they were not. I commented them out there too and am now able to export the file I needed without the authentication prompt. Thank you again for sharing your knowledge on this.

      Dave

      Comment


      • #4
        Glad that worked out quickly - cheers!

        Comment

        Working...
        X