Announcement

Collapse
No announcement yet.

Interactive Command Line and Windows 10 1803

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Interactive Command Line and Windows 10 1803

    So this seems to be an issue with all interactive prompts in the command-line, i have tried this on 2 different machines,
    one being brand new install of windows with updates
    one being an existing windows install updated to 1803 (that had this working previously)

    The problem comes in when you are working with the command prompt (and batch files by extension)

    When you attempt to check out from a repo with a selfsigned ssl (that you havent previously excepted) or attempt to login with a password or username it will accept the first character but nothing else.

    Basic Steps i have to reproduce
    prereqs:
    1) Windows 10 v 1803
    2) Installed TortoiseSVN 1.10.0 w/ Command Line Utilities

    steps:
    1) open command prompt
    2) Attempt to checkout a SVN repo that will cause an interactive response (HTTPs with Self Signed Cert, UserName/Password protected repo)
    3) attempt to proceed thru the prompt (for ssl attempt to accept, login attempt to login)

    accepts a single character and stops accepting input (you actually hear a background windows sound if you keep typing with each key press)


    Any Ideas? I have been fighting with this for about 2 days now since I can not roll out new windows updates to other developers because of this problem.

    Before it is asked,
    I have tried with windows defender completely disabled and no other virus scanner or realtime threat detection on or installed.

  • #2
    Explicitly, what prompt text is displayed? The prompt I'd expect (it's been a while - I'm working from memory) is the one to accept the untrusted certificate and is only expecting a single character (with 'p' - permanent, 't' - temporary, or some character for "don't trust" as possible replies).

    Comment


    • #3
      [QUOTE=DougR;n80335]Explicitly, what prompt text is displayed? The prompt I'd expect (it's been a while - I'm working from memory) is the one to accept the untrusted certificate and is only expecting a single character (with 'p' - permanent, 't' - temporary, or some character for "don't trust" as possible replies).[/QUOTE]

      Hello DougR,

      You would be correct. It expects only a single character for the input but you can normally put multiple. I used it as a reference because Both the Untrusted Cert screen and login prompt via the interactive command line interface are failing very similarly, if not the same.

      I suspect something is trigger windows to intercept the inputs (for whatever reason) because of the background sounds I hear when i continue to type after the first character

      Thanks
      Paul

      Comment


      • #4
        At this point, I'm thinking TortoiseSVN bug. Have you checked directly with the TortoiseSVN folks? Cheers.

        Comment

        Working...
        X