Announcement

Collapse
No announcement yet.

Authentication Failed after Repository Move

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • TonyV
    replied
    Thanks for the suggestions Doug. I'll try again sometime in the next couple of days with a log file set up.

    Regards
    Tony

    Leave a comment:


  • DougR
    replied
    The first thing that I'd do is enable svnserve to log stuff. Add the "--log-file /home/svnuser/SVN/svnserve.log" (or something like that). Logging can really help you diagnose the issue.

    FYI, the "svnserve" man page is inadequate: to see all of the options type "svnserve --help".

    Leave a comment:


  • DougR
    replied
    I found the text of your post:
    ------------------------------------
    Hi

    The files are as follows:

    /etc/inetd.conf

    svn stream tcp nowait svnuser /opt/freeware/bin/svnserve svnserve -i -r /home/svnuser/SVN/repos


    svnserve.conf

    [general]
    anon-access = none
    auth-access = write
    password-db = /home/svnuser/SVN/conf/passwd
    authz-db = /home/svnuser/SVN/conf/authz
    realm = DBA Repository
    force-username-case = lower

    I modified these files as part of the move to reflect the new repository location. The values shown here are the original values which is what I had to revert back to after the move failed.

    Many thanks

    Tony

    Leave a comment:


  • DougR
    replied
    TonyV - somehow the forum software glitched and deleted your post. Could you try again? Sorry.

    Leave a comment:


  • DougR
    replied
    Could you provide your inetd.conf entry? And the svnserve.conf file?

    Leave a comment:


  • TonyV
    started a topic Authentication Failed after Repository Move

    Authentication Failed after Repository Move

    Hi

    I am trying to move a Subversion repository from one location to another on the same Unix server.

    The repository version is 1.9.5 and the O/S is AIX.

    After reading the 'Moving and Removing Repositories' section in the Subversion manual,
    I used the O/S 'cp -rp' command to copy the repository from source to target.

    The repository is accessed using the 'svn' protocol, which I understand uses the inetd
    daemon to handle connections. So I modified /etc/inetd.conf to point to the new repository.

    The svnserve.conf file was also amended to reflect the new locations for passwd and authz
    files.

    The first time I tried to access the repository using something like 'svn list svn://server.domain/repos'
    I got a network connection error message. So I tried bouncing the inetd daemon.

    The error then changed to 'E215004 authentication failed' and I can't figure out why I am getting this.

    Can anybody see what I've done wrong?

    Many Thanks
    Tony
Working...
X