Announcement

Collapse
No announcement yet.

Use SVN (via HTTPS) without authentication - is that possible?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Use SVN (via HTTPS) without authentication - is that possible?

    Hi there

    Use SVN (via HTTPS) without authentication - is that possible? E.g. with "AuthType none" or something like that?


    Apache config is here:

    # DOMAIN: SVNSERVER
    <VirtualHost *:80>
    ServerName SVNSERVER
    ServerAlias SVNSERVER [url]www.SVNSERVER[/url]
    ServerAdmin [email]xxx@yyy.zzz[/email]
    DocumentRoot "C:/AWServer/www/admin/public_html/SVNSERVER"
    php_admin_value open_basedir "C:/AWServer/www/admin/public_html/SVNSERVER;C:/AWServer/www/admin/tmp;C:/AWServer/temp;C:/AWServer/bin/php/PEAR;C:/AWServer/bin/imagick"
    php_admin_value suhosin.executor.func.blacklist "system, exec, shell_exec, passthru, proc_terminate, proc_nice, escapeshellcmd, escapeshellarg, popen, pclose, show_source, leak, apache_child_terminate, posix_kill, posix_mkfifo, posix_setpgid, posix_setsid, posix_setuid, pcntl_exec"
    php_admin_value upload_tmp_dir "C:/AWServer/www/admin/tmp"
    php_admin_value session.save_path "C:/AWServer/www/admin/tmp"
    php_admin_value memory_limit 128M
    ErrorLog "C:/AWServer/logs/domains/admin/SVNSERVER-error.log"
    CustomLog "C:/AWServer/logs/domains/admin/SVNSERVER-access.log" combined
    CustomLog "C:/AWServer/logs/domains/admin/SVNSERVER-bandwidth.log" common
    <Directory "C:/AWServer/www/admin/public_html/SVNSERVER">
    # Options FollowSymLinks
    Options Indexes FollowSymLinks
    # AllowOverride All
    AllowOverride None
    Order Allow,Deny
    Allow from all
    </Directory>
    DirectoryIndex index.php index.html index.htm index.shtml index.shtm index.pl
    AddType application/x-httpd-php .php
    ScriptAlias /cgi-bin/ "C:/AWServer/www/admin/public_html/SVNSERVER/_cgi-bin/"
    <Location /cgi-bin>
    SetHandler perl-script
    SetHandler cgi-script
    PerlResponseHandler ModPerl::Registry
    PerlOptions +ParseHeaders
    Options +ExecCGI
    </Location>

    <Location /php_repo>
    DAV svn
    SVNPath C:/AWServer/www/admin/public_html/SVNSERVER/php_repo
    AuthType none
    </Location>

    <Location /java_repo>
    DAV svn
    SVNPath C:/AWServer/www/admin/public_html/SVNSERVER/java_repo
    AuthType none
    </Location>

    <Location /dotnet_repo>
    DAV svn
    SVNPath C:/AWServer/www/admin/public_html/SVNSERVER/dotnet_repo
    AuthType none
    </Location>

    ErrorDocument 403 /_errorpages/403.html
    ErrorDocument 404 /_errorpages/404.html
    ErrorDocument 500 /_errorpages/500.html
    ErrorDocument 510 /_errorpages/510.html

    # Custom global settings are loaded below this line (if any exist)

    # Custom vhost settings are loaded below this line (if any exist)

    </VirtualHost>
    # END DOMAIN: SVNSERVER



    But it always shows me the following in browser:
    [TABLE]
    [TR]
    [TD] [/TD]
    [TD]<?xml version="1.0" encoding="utf-8"?>[/TD]
    [/TR]
    [TR]
    [TD] [/TD]
    [TD]<D:error xmlns:D="DAV:" xmlns:m="http://apache.org/dav/xmlns" xmlns:C="svn:">[/TD]
    [/TR]
    [TR]
    [TD] [/TD]
    [TD]<C:error/>[/TD]
    [/TR]
    [TR]
    [TD] [/TD]
    [TD]<m:human-readable errcode="160043">[/TD]
    [/TR]
    [TR]
    [TD] [/TD]
    [TD]Could not open the requested SVN filesystem[/TD]
    [/TR]
    [TR]
    [TD] [/TD]
    [TD]</m:human-readable>[/TD]
    [/TR]
    [TR]
    [TD] [/TD]
    [TD]</D:error>[/TD]
    [/TR]
    [TR]
    [TD] [/TD]
    [TD] [/TD]
    [/TR]
    [/TABLE]

    (Can't be a permission problem, because the repo directories are subdirectories of C:/AWServer/www/admin/public_html/SVNSERVER = C:/AWServer/www/admin/public_html/SVNSERVER/php_repo


    Currently, i use apache 2.2.9 with that config:

    #user
    LoadModule dav_module modules/mod_dav.so
    LoadModule dav_svn_module modules/mod_dav_svn.so
    #LoadModule authz_svn_module modules/mod_authz_svn.so
    #LoadModule authz_svn_module modules/mod_dontdothat.so


    The .so libraries i use are from: "svn-win32-1.8.17.zip" ([url]https://sourceforge.net/projects/win32svn/[/url])

    The repositores i created with the most current version of slikk svn: Slik-Subversion-1.9.7-win32.zip


    Thank you for your feedbacks


    With best regards,
    Jan

  • #2
    Apache permissions problems can be caused by all sorts of things. Permission on the libraries needed to share, permissions on directories above the directories for your repos. While you assert that it can't be a permissions problem, I have seen many, many people create repositories using the wrong account in the correct directory causing failures like this. Happens all the time.


    I assume that you created the repo where you told Apache it would be? And the account you used to create the repo was the same as the account that Apache runs as? And is the same as the account that all of the Apache, Subversion, etc. bits are loaded from?

    Note: you should be getting Apache and Subversion from the same build: doing anything less will end in failure so I assume that the Slik-Subversion packaging includes both Apache and Subversion? If not, then you need to go elsewhere or build it yourself (no mean feat).

    Also, Apache 2.2 is rather long in the tooth - unsupported even: you should transition to 2.4 as quickly as possible.

    Comment


    • #3
      Hi DougR

      Thank you for your feedback, I've found the reason of the problem: The Apache .so libraries i used are version 1.8.x, and the repositories were created by "SlikSVN" in version 1.9.x.

      When i use the version 1.8 flag/parameter for "svnadmin create", then it works...


      With best regards,
      Jan

      Comment


      • #4
        Glad you found the problem! Cheers.

        Comment

        Working...
        X