Announcement

Collapse
No announcement yet.

Create Branch / Delete commits - Access Denied

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Create Branch / Delete commits - Access Denied

    Hi,

    Been using SVN for over 2 years without a problem until few weeks ago when I started to get access denied when trying to create branches in Repo Browser or even on the SVN command line.
    e.g. Using svn copy -m "branch from command line" "svn://myserver/myproject/trunk" "svn://myserver/myproject/branches/test"
    I get
    Committing transaction...
    svn: E220004: Access denied


    I can open Repo Browser and create a folder on the server no problem... but I cannot delete it. I also get "Access Denied" for this.

    Nothing has changed in the config for the server, I still have the same permissions the other devs have... and they can create branches.

    I have tried clearing auth credentials etc.... tried deleting entire local repo and recreating.... tried reinstalling tortoiseSVN.... all to no avail.


    I have seen posts about readonly files in your local repo... which I appear to have loads of in the .svn folder.
    But am I right in thinking svn copy operates purely on the server ?

    How can I troubleshoot this further and hopefully find a fix for ?

    I am using the latest tortoisesvn (1.10)

    thanks

  • #2
    The command you gave as an example has nothing to do with a local working copy. So don't bother thinking about the WC.

    Do you know what version of Subversion is running on your server? Since you're using the "svn:" protocol that really narrows the possibilities. I'm afraid that to proceed further we'll need to understand what the SVN Authorization file has in it for your account (vs. other accounts). For instance, if your server is running 1.10 (or even a modified 1.9) then it is possible that someone is using wildcards in the AuthZ file: if so then that could actually explain it. But, to verify, I'd need to see the AuthZ file (or at least a redacted form of it).

    Comment


    • #3
      Hey DougR,

      Thanks for the quick response.
      I've attached a redacted AuthZ file.
      I can't see anything different between me and the other devs tbh.

      The server is running 1.7 I think.

      thanks
      Attached Files

      Comment


      • #4
        Assuming the redacted AuthZ file is accurate then I agree there is something fishy going on. I suggest that you turn on logging for the "svnserve" command on your server (if not already on) and see what's in that log file. Might help diagnose the problem.

        Comment


        • #5
          The second path actually contains spaces.

          So should have been more like

          [/protected path]
          * = r
          dev1 = rw
          dev2 = rw
          dev3 = rw

          After asking more devs it appears all except the devs listed for the protected path are experiencing the issue, even though the folder we are trying to delete is not under the /protected path
          Turns out this protected path was added quite recent... so they are going to revert it tomorrow to see if that solves the issue.

          thanks

          Comment


          • #6
            FWIW, SVN 1.7 is "ancient history": really needs updating as there are a lot of bugs fixed since then. Don't need to go all the way up to 1.10.0 but that should be fine (per compatibility requirements of SVN community). Could choose latest 1.9 if you want to be conservative.

            And seeing what's in the log files might help you diagnose the root cause. Cheers.

            Comment

            Working...
            X