No announcement yet.

Cannot connect to a repository in TortoiseSVN v1.9.7

  • Filter
  • Time
  • Show
Clear All
new posts

  • Cannot connect to a repository in TortoiseSVN v1.9.7

    [FONT=trebuchet ms]Hello dear community,
    I have a really strange problem and I am trying to solve it for four days..

    To checkout and checkin my code I am using the latest TortoiseSVN client and for our project we are useing the VisualSVN Server.
    Everything works fine. After my vacations I checked out the project without any problems. Later I wanted to check in my changes but i couldn't suddenly... Instead of that I got that error msg:

    Unable to connect to a repository at URL 'https://our-server/svn/our-project'
    Error running context: The requested address is invalid in this context.

    If I visit the URL in a internet browser everything works fine. We tried the following steps to solve the problem:

    Update the Server to the latest version
    Change the Ports
    Change from https to http
    downgrade the ToirtoiseSVN client to an older version
    Try to check out from command line
    Completely delete TortoiseSVN and Subversion (incl. registery entries) and reinstall it
    Try other svn clients like SmartSVN --> same error msg
    Try the in Adobe Dreamweaver integrated svn client --> same error msg
    Change IP-Adress
    Reinstall the certificate
    Try to check out from an other user account

    The most curious thing is that when I try the URL 'https://our-server/svn' in the repository-browser I am able to see all our projects but when I try to click into the single folder I get the error msg again.

    Does anyone have an idea?
    I have Windows 10 Fall Creatos (1709)

    I really appriciate every kind of help or tipp to solve this problem.

    Best regards
    Last edited by Plescko; 12-08-2017, 10:50 PM.

  • #2
    Seems to me like something is going wrong with the AuthZ processing. You should see how AuthZ is setup and check to see if there were any changes to the AuthZ file? Perhaps someone updated the AuthZ setting in VisualSVN and broke you.

    On a completely different track you might try a “svn relocate” using the latest URL. That might fix things up if any IP’s changed, etc.