Announcement

Collapse
No announcement yet.

VisualSVN and team city not connecting... 405 method not allowed ...

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • VisualSVN and team city not connecting... 405 method not allowed ...

    Hello,

    I am using VisualSVN with Team city and I am getting a "405 method not allowed" error.

    ANY help would be much appreciated

    Please see the attached document for details ([NOTE: docx document removed for safety's sake. PDF required.])
    Last edited by DougR; 11-16-2017, 04:23 PM.

  • #2
    Also, when I try to start the repobrowser I get "method 'OPTIONS' is not allowed" ( see attachment )
    Attached Files

    Comment


    • #3
      What is interesting to note is both of these occurrences happen on the "Reports1.Cetrus.com" machine... and on my local machine... I can access the repo simply by using: [url]https://someIPAddress/svn/Service/4.0/branches[/url] (when I ignore the certificate error).
      Last edited by DougR; 11-16-2017, 04:30 PM. Reason: Eliminate real hlink for safety.

      Comment


      • #4
        Had to remove your "docx" file. If you want to attach a document then it should be a PDF or TXT file. Also eliminate your live hyperlink/URL. Nothing that can be used to transport unhappiness.

        As for the "OPTIONS" not allowed (405), you might want to investigate how your server is configured.
        Last edited by DougR; 11-16-2017, 04:31 PM.

        Comment


        • #5
          You gotta be kidding me... 19.5 kb attachment limit? what year is this 1980?

          Comment


          • #6
            Here is my Visual SVN
            If you need any more information... let me know... I can provide anything you want
            Last edited by MrLister; 11-16-2017, 05:50 PM.

            Comment


            • #7
              Here is the URL I get from Visual SVN

              Comment


              • #8
                Here is a ping to the source server from my local box...
                NOTE the ping to the Reports1.Cetrus.com works !
                Last edited by MrLister; 11-16-2017, 05:49 PM.

                Comment


                • #9
                  Here is how I have configured the Visual SVN URL in team city's Parameters:

                  Comment


                  • #10
                    Here is how I have every module within TeamCity setup to access source control

                    Comment


                    • #11
                      In the modules "setup"... I have the following: ( NOTE user name and password ARE correct )

                      Comment


                      • #12
                        This is the error message I get:

                        Comment


                        • #13
                          here is full message:
                          -
                          Test connection failed in PM4 :: ManagerService
                          Error connecting the specified URL:
                          svn: E175002: OPTIONS of '/svn/Service/4.0/trunk/ManagerService': 405 Method Not Allowed ([url]https://myserver.mycompany.com[/url])
                          Last edited by DougR; 11-16-2017, 06:22 PM.

                          Comment


                          • #14
                            This appears to be some issue with VisualSVN. I can help with Apache, but I have zero experience with VisualSVN. Hopefully someone else here can help? Or contact your VisualSVN support folks?

                            Comment


                            • #15
                              Thank you DougR... much appreciated

                              Comment

                              Working...
                              X