Announcement

Collapse
No announcement yet.

SVN Commit/import timeout

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • SVN Commit/import timeout

    I have setup a svn repo and when I try to import/commit it gives a timeout error. I tried via command line and tortoise client but commit gives a timeout. But I can checkout from server with no issues. I have disabled SElinux/iptables in the server as well. Any help solving this is mush appreciated since I am stuck here over a month.
    Attached Files

  • #2
    Since you're using Apache please check your Apache log files. They should be located in the "/var/log/httpd" directory. Check for time-stamps at or slightly after your attempts at pushing. If you can share them please post them up.

    Comment


    • #3
      Thank you for the respond. I tried them but could not find any clue related to this issue. Below is the output of access log there was nothing recorded in error log. let me know if you need more info.

      172.25.12.81 - - [06/Feb/2017:19:45:49 +0530] "OPTIONS /svn/MIT_REPO HTTP/1.1" 401 401
      172.25.12.81 - test [06/Feb/2017:19:45:52 +0530] "OPTIONS /svn/MIT_REPO HTTP/1.1" 200 192
      172.25.12.81 - test [06/Feb/2017:19:45:52 +0530] "OPTIONS /svn/MIT_REPO HTTP/1.1" 200 97
      172.25.12.81 - test [06/Feb/2017:19:45:52 +0530] "OPTIONS /svn/MIT_REPO HTTP/1.1" 200 192
      172.25.12.81 - test [06/Feb/2017:19:45:52 +0530] "PROPFIND /svn/MIT_REPO/!svn/rvr/0 HTTP/1.1" 207 733
      172.25.12.81 - test [06/Feb/2017:19:45:52 +0530] "OPTIONS /svn/MIT_REPO HTTP/1.1" 200 192
      172.25.12.81 - test [06/Feb/2017:19:45:52 +0530] "PROPFIND /svn/MIT_REPO HTTP/1.1" 207 265
      172.25.12.81 - - [06/Feb/2017:19:45:52 +0530] "OPTIONS /svn/MIT_REPO HTTP/1.1" 401 401
      172.25.12.81 - test [06/Feb/2017:19:45:52 +0530] "OPTIONS /svn/MIT_REPO HTTP/1.1" 200 192
      172.25.12.81 - test [06/Feb/2017:19:45:52 +0530] "OPTIONS /svn/MIT_REPO HTTP/1.1" 200 97
      172.25.12.81 - test [06/Feb/2017:19:45:52 +0530] "OPTIONS /svn/MIT_REPO HTTP/1.1" 200 192
      172.25.12.81 - test [06/Feb/2017:19:45:52 +0530] "PROPFIND /svn/MIT_REPO/!svn/rvr/0 HTTP/1.1" 207 327
      172.25.12.81 - test [06/Feb/2017:19:45:52 +0530] "OPTIONS /svn/MIT_REPO HTTP/1.1" 200 192
      172.25.12.81 - test [06/Feb/2017:19:45:52 +0530] "REPORT /svn/MIT_REPO/!svn/me HTTP/1.1" 200 598
      172.25.12.81 - - [06/Feb/2017:19:46:10 +0530] "OPTIONS /svn/MIT_REPO HTTP/1.1" 401 401
      172.25.12.81 - test [06/Feb/2017:19:46:13 +0530] "OPTIONS /svn/MIT_REPO HTTP/1.1" 200 192
      172.25.12.81 - test [06/Feb/2017:19:46:13 +0530] "OPTIONS /svn/MIT_REPO HTTP/1.1" 200 97

      Comment


      • #4
        I don't see anything wrong with the log entries you posted above.

        Could you share your Apache config files (redact any IP addresses and/or hostnames and other private stuff first please)?

        Comment


        • #5
          That's why I am stuck here. I cannot find any error to fix this. I checked with network team and there is no firewall restriction to server as well.
          I have attached httpd.onf,https-vhost.conf,svn policy and auth file. let me know if you can help with these or if you need more info.
          Attached Files

          Comment


          • #6
            I assume that you've obfuscated the "ServerName", "ErrorLog" and "CustomLog" lines. If not then you should make sure that they match a the DNS entry (or alias) for that host. Otherwise it is possible that the client will get re-directed to a non-existent server and timeout.

            Another possibility is that your server has SELinux turned on (run the "sestatus" command as root" to determine this). If it is enabled then it will make things very, very difficult for you. It is best to turn things off when initially setting up your server. Then turn it on in permissive mode, capturing the necessary policy information. Then use "audit2allow" to create a policy that will enable those operations that you tested during the permissive mode. After that you can turn it back on full strength.

            Comment


            • #7
              I put server ip as the servername and defined errot log and custom log in virtualhost file. Thing is I can navigate to my repo via a web browser. Also I can check out from this repo with tortoise client.

              Also I have disabled selinux in the server. could not figure it out what I have missed here. ;(

              Comment


              • #8
                Ok, found something. Not sure this is it but likely. See here: [URL="http://grokbase.com/t/subversion/users/14ae68s0dt/svn-1-8-timeout-fix"]http://grokbase.com/t/subversion/use...-8-timeout-fix[/URL]

                Their solution: setting SVNAllowBulkUpdates to Prefer and enabling "KeepAlive" and setting MaxKeepAliveRequests" to 1000.

                Try that. If it works then it's likely time to upgrade your server!

                What version of SVN are you using on your Server? Which Server OS? (cat /etc/*release*)
                Last edited by DougR; 02-09-2017, 08:01 PM.

                Comment


                • #9
                  Also, how big are your commits?

                  Comment


                  • #10
                    I tried enabling SVNAllowBulkUpdates and enabling "KeepAlive" but no luck. however below are versions
                    [root@svn-72-64 extra]# svn --version
                    svn, version 1.9.4 (r1740329)

                    [root@svn-72-64 conf]# cat /etc/*release
                    LSB_VERSION=base-4.0-amd64:base-4.0-noarch:core-4.0-amd64:core-4.0-noarch:graphics-4.0-amd64:graphics-4.0-noarch:printing-4.0-amd64:printing-4.0-noarch
                    Red Hat Enterprise Linux Server release 6.6 (Santiago)
                    Red Hat Enterprise Linux Server release 6.6 (Santiago)


                    and also I could not do a single commit to this repo yet and trying a small file ( empty text file ) for testing.

                    Comment


                    • #11
                      I also feel this should be serf or some kind of library issue. as per my understanding all the configurations seems ok. Only problem here is I don't get any error where i can follow to get a solution.

                      Comment


                      • #12
                        Try a local commit and see what happens? Or perhaps turn up the logging on Apache?

                        Comment

                        Working...
                        X