Announcement

Collapse
No announcement yet.

subversion 1.6 copied via rync no problems accessing the repos

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • subversion 1.6 copied via rync no problems accessing the repos

    hi there. I have a new server with subversion 1.8. I copied the data from a 1.6 Version. Now I have problem like invalid authz configuratione etc.
    Is there a possibility to upgrade the data. Svn upgrade says its not a working copy. I want to upgrade the base repos.

  • #2
    There are 2 ways to upgrade repos:
    1. "svnadmin upgrade"
    2. "svnadmin dump | svnadmin load"

    The former will help but will not enable the best features enabled by the newer SVN releases. Only the latter will enable all of the new features.

    Also, if you're just loading up a new server, I'd suggest you jump up directly to SVN 1.9.4 !

    Comment


    • #3
      One other thing to note: it's ok to "rsync" (copy) the repository bits from "like to like" in terms of OS-flavor and Bit-ness, but not "like to unlike". So if you're moving from Windows to Linux (or from 32-bit to 64-bit or both) then you should always "svnadmin dump" on the "from" system and "svnadmin load" on the "to" system.

      Comment

      Working...
      X