No announcement yet.

An error occurred during authentication with Windows 10 IIS reverse proxy??

  • Filter
  • Time
  • Show
Clear All
new posts

  • DougR
    Congrats on figuring this one out - and Thank You for posting the solution. Cheers!

    Leave a comment:

  • jmar83
    Hallo DougR

    It was solved - the problem was that i was using IIS "Windows Authenication" instead of "Standard Authentication" - but both things show the same behavoir on browser (from the view of a end user) - at least if another browser than IE/Edge is used and the computer is not a member of a domain.

    In both cases you can see the browser-specific dialog to enter username and password. (like basic/digest authentication)... but inside (on request/response level), it seems to be completely different.

    The only thing i want was an authentication over windows user account from my iis (the SVN apache webserver behind the IIS revese proxy has no logins and a private IP), now i was sucessful with "Standard Authentication"...



    Leave a comment:

  • DougR
    Do you see any log file entries from Apache? If not then the problem is with IIS.

    IIS and Apache are different processes. Since you want AuthN to be done in IIS against Windows, how are you passing the account-name to Apache?

    FWIW, I don't see how Git will help (in this case).

    Leave a comment:

  • An error occurred during authentication with Windows 10 IIS reverse proxy??

    Hi there!

    Now i installed Windows 10 x64 Pro a new virtualisation host system which also has a role as reverse proxy with IIS to use "Windows Authentication", before i used Windows 7 x64 Pro. The settings on the SVN apache webserver virtual machine are still the same...

    But now, with Win10 instead of Win7 as reverse proxy, i get that error message:

    "An error occurred during authentication"

    - The SSL certificate is not from an offcial certificate issuer, it's generated by Win10 IIS
    - The login is 100% correct, when i visit the URL in the browser i see the SVN directories

    - I also tried:
    - Disabling the "RequestFilteringModule" in IIS -> does not work
    - Disabling IIS "Compression of static contents" -> does not work

    - The other "special" settings of apache SVN are the following
    - Disabling "mod_deflate"
    - Enabling "mod_headers" and adding that line the svn vhost: RequestHeader edit Destination ^https: http: early

    My first thread regarding to problems with IIS reverse proxy (at that time, it was Win7!) is here:

    And it is also not a problem of my eclipse svn plugin, "TourtoiseSVN" gives me the same error message, after first entering of username and password...

    I'm working on that problem since 2-3 days, but i didn't found a solution to solve it. (Maybe to using GIT is the solution, who knows?? )