Announcement

Collapse
No announcement yet.

Errors: Working copy is not up-to-date, svn commit failed & filesystem has no item

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Same problem with wandisco -> http://opensource.wandisco.com/subve...n_1.8.17-1.exe

    Regards,
    Jan

    Comment


    • #17
      https://riouxsvn.com/ works without any problems, i used this just for testing..


      visualsvn 2.7.14 (https://www.visualsvn.com/server/download/2.7/) also stops on the same directory with that error:

      org.apache.subversion.javahl.ClientException: RA layer request failed
      svn: Commit failed (details follow):
      svn: Adding directory failed: MKCOL on /php_repo/!svn/txr/5-5/myproject/subdomains/newsite/src/vendor/symfony/54/finder/Tests/Fixtures/r+e.gex%5Bc%5Da(r)s (404 Not Found)

      org.apache.subversion.javahl.ClientException: RA layer request failed
      svn: Commit failed (details follow):
      svn: Adding directory failed: MKCOL on /php_repo/!svn/txr/5-5/myproject/subdomains/newsite/src/vendor/symfony/54/finder/Tests/Fixtures/r+e.gex%5Bc%5Da(r)s (404 Not Found)



      - visualsvn 2.7.14 has subversion 1.8.15 integrated, .so libraries AND svnadmin.exe (which i used to create repo)

      - the eclipse subclipse plugin i use now is for svn version 1.8.x -> https://dl.bintray.com/subclipse/arc...elease/1.10.x/ -> https://github.com/subclipse/subclipse/wiki ("SVN 1.8.x - https://dl.bintray.com/subclipse/archive/release/1.10.x/")
      ...and it's JavaHL version is EXACTLY for 1.8.15 = "JavaHL (JNI) 1.8.15 (r1718365)", i see that in Eclipse Team -> SVN settings....

      WTF is that s**t?!??


      Regards,
      Jan
      Last edited by jmar83; 05-10-2018, 02:36 PM.

      Comment


      • #18
        org.tigris.subversion.svnclientadapter.SVNClientEx ception: org.apache.subversion.javahl.ClientException: RA layer request failed
        svn: Commit failed (details follow):
        svn: Adding directory failed: MKCOL on /php_repo/!svn/txr/5-5/myproject/subdomains/newsite/src/vendor/symfony/54/finder/Tests/Fixtures/r+e.gex%5Bc%5Da(r)s (404 Not Found)

        at org.tigris.subversion.svnclientadapter.javahl.Abst ractJhlClientAdapter.commit(AbstractJhlClientAdapt er.java:347)
        at org.tigris.subversion.subclipse.core.commands.Chec kinResourcesCommand$1.run(CheckinResourcesCommand. java:146)
        at org.tigris.subversion.subclipse.core.SVNProviderPl ugin$6.run(SVNProviderPlugin.java:535)
        at org.eclipse.core.internal.resources.Workspace.run( Workspace.java:2240)
        at org.eclipse.core.internal.resources.Workspace.run( Workspace.java:2267)
        at org.tigris.subversion.subclipse.core.SVNProviderPl ugin.run(SVNProviderPlugin.java:530)
        at org.tigris.subversion.subclipse.core.commands.Chec kinResourcesCommand.run(CheckinResourcesCommand.ja va:121)
        at org.tigris.subversion.subclipse.core.SVNTeamProvid er.checkin(SVNTeamProvider.java:139)
        at org.tigris.subversion.subclipse.ui.operations.Comm itOperation.execute(CommitOperation.java:116)
        at org.tigris.subversion.subclipse.ui.operations.SVNO peration.run(SVNOperation.java:90)
        at org.eclipse.team.internal.ui.actions.JobRunnableCo ntext.run(JobRunnableContext.java:151)
        at org.eclipse.team.internal.ui.actions.JobRunnableCo ntext$ResourceJob.runInWorkspace(JobRunnableContex t.java:76)
        at org.eclipse.core.internal.resources.InternalWorksp aceJob.run(InternalWorkspaceJob.java:39)
        at org.eclipse.core.internal.jobs.Worker.run(Worker.j ava:56)
        Caused by: org.apache.subversion.javahl.ClientException: RA layer request failed
        svn: Commit failed (details follow):
        svn: Adding directory failed: MKCOL on /php_repo/!svn/txr/5-5/myproject/subdomains/newsite/src/vendor/symfony/54/finder/Tests/Fixtures/r+e.gex%5Bc%5Da(r)s (404 Not Found)

        at org.apache.subversion.javahl.SVNClient.commit(Nati ve Method)
        at org.tigris.subversion.svnclientadapter.javahl.Abst ractJhlClientAdapter.commit(AbstractJhlClientAdapt er.java:339)
        ... 13 more
        Last edited by jmar83; 05-10-2018, 10:34 AM.

        Comment


        • #19
          I can see how the name "r+e.gex[c]a(r)s" could stress the SVN/Windows interfacing. But not the other one ("/myproject/subdomains/www/src/wp-content/plugins/w3-total-cache/ini/web.config") so I wonder if there is some UTF8/16 strangeness going on (it shouldn't matter but...)?

          In general, using a Linux server here might be your quickest way out. This would appear to be a bug in SVN - at least when hosted on Windows. If so, I'd jump all the way up to SVN 1.10.0 to get the most complete set of fixes. But that's me. I'd likely do a dump/load-into-newest-repo-format to get all of the new features too. If your repos are big enough I can understand not doing this.
          Last edited by DougR; 05-10-2018, 02:08 PM.

          Comment


          • #20
            Thank you for your feedback. Now i've found the problem!!

            I just need to disable the IIS 7.5 request filter ("RequestFilteringModule" - something like a web application firewall, the name "web.config" is blacklisted there ), i use IIS as a reverse proxy, e.g. for user authentication (-> my first thread) and https.

            But now i have a "An error occurred during decompression" (at the end of the process -> "Transmitting file data ..."), maybe "SetEnv no-gzip 1" in the apache svn vhost config will solve the problem? (Or is it caused by IIS? But that's another thing..)


            Regards, Jan

            Comment


            • #21
              If you're configured to use "mod_deflate" you should turn it off.

              Glad you're making progress!

              Comment


              • #22
                "SetEnv no-gzip 1" does not seems to work, same problem: "APR does not understand this error code", "An error occurred during decompression"

                Will try it with disabling mod_deflate!

                Regards, Jan

                Comment


                • #23
                  No, it was neither "mod_deflate" nor the "SVNCompression 0" or "SetEnv no-gzip 1" parameters...

                  I commented that line and the problem with "An error occurred during decompression" is gone:

                  # AddEncoding x-gzip gz tgz


                  Regards,
                  Jan
                  Last edited by jmar83; 05-11-2018, 02:30 PM.

                  Comment


                  • #24
                    SVN client-side "http-compression" parameter was also not solving the problem...

                    Regards, Jan

                    Comment


                    • #25
                      Now i tried with with IIS 7.5 reverse proxy (with https and user auth), before i tried it directly with apache SVN server, works without any problems too!!

                      Regards,
                      Jan

                      Comment


                      • #26
                        Not sure what you're reporting: Does it work without IIS 7.5 and fail with IIS 7.5?

                        Comment


                        • #27
                          No, to exclude other problems, i tested it without the IIS 7.5 forward proxy... then i saw the decompression error. after removing that line in configuration, it was working. Then i used it WITH the forward proxy without new problems...

                          Regards, Jan

                          Comment


                          • #28
                            Glad things are working now. Cheers.

                            Comment


                            • #29
                              Now i had a new problem, "both sides of the move must be committed together" after renaming of files or directories.. when i tried to commit the renamed objects (file, directory), then i got that message. When i tried to commit the parent directory, i got a 502 error...

                              A workaround would be to delete the old file/directory, and copy its content into the new one. but it kills the history, so it's not a solution..

                              So i read that: http://www.dscentral.in/2013/04/04/5...reverse-proxy/

                              it's related to SSL off-loading, and a problem with many SSL forward-proxy and webserver configurations, not only IIS and/or Apache.

                              The following line, defined on apache virtual host level, has solved my problem:

                              RequestHeader edit Destination ^https: http: early


                              Maybe another solution is to change the reverse proxy configuration (#2 on http://www.dscentral.in/2013/04/04/5...reverse-proxy/), but i don't want to change the IIS 7.5 too much...


                              Regards, Jan
                              Last edited by DougR; 05-15-2018, 12:25 PM. Reason: HTML on.

                              Comment

                              Working...
                              X