Announcement

Collapse
No announcement yet.

Will SmartSVN 7.6 automatically update to SmartSVN 8?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Will SmartSVN 7.6 automatically update to SmartSVN 8?

    Hi

    I have copied the following question from the 'SmartSVN Early Access Feedback' forum to here because I think here is more appropriate:

    I have installed SmartSVN 7.6 and it is set to automatically download and install updates. When SmartSVN 8 is released, will my SmartSVN client automatically upgrade itself to version 8 and upgrade my working copies to svn 1.8 format?

    That would not be desirable as I use other svn clients as well as SmartSVN and they may still be at svn 1.7.

    Best regards

    David

  • #2
    Hi there,

    SmartSVN 7.6 will automatically update to SmartSVN 8 once it's released, but it won't automatically upgrade your working copy. SmartSVN 8 will be compatible with Subversion 1.7 and 1.8, so it will be up to you to make the switch once you're ready to do so.

    Comment


    • #3
      Originally posted by Mand View Post
      Hi there,

      SmartSVN 7.6 will automatically update to SmartSVN 8 once it's released, but it won't automatically upgrade your working copy. SmartSVN 8 will be compatible with Subversion 1.7 and 1.8, so it will be up to you to make the switch once you're ready to do so.
      Hi Mand

      Thanks for your answer. That sounds good. I hope that if it does offer to upgrade the working copy, there will be a clear warning message stating the implications. Actually, I would prefer it not to offer to upgrade the wc at all - just leave it to the user to decide when to do it.

      BR

      David

      Comment


      • #4
        I upgraded to smartsvn 8 and it refuses to work without upgrading the working copy format to 1.8. Since I have svn integration in other software which I cannot upgrade yet, this means I now have to spend the time to downgrade smartsvn. I am not amused.

        Comment


        • #5
          Originally posted by Mand View Post
          Hi there,

          SmartSVN 7.6 will automatically update to SmartSVN 8 once it's released, but it won't automatically upgrade your working copy. SmartSVN 8 will be compatible with Subversion 1.7 and 1.8, so it will be up to you to make the switch once you're ready to do so.
          I just upgraded to SmartSVN 8, and it is requiring me to upgrade my working copy to subversion 1.8. Since this is incompatible with our build environment I cannot do this at present.

          I have re-checked the download page (http://www.wandisco.com/smartsvn/download-all) and this states quite clearly that it should work with subversion 1.7:
          Requirements
          SmartSVN requires a Java Runtime Environment (JRE) 1.6 or higher to run. We recommend to use the latest JRE to be able to use all features.

          ...

          SmartSVN version 8 works with Subversion 1.6, 1.7 and 1.8 binaries.
          Please can you confirm whether there is an undocumented way of avoiding the upgrade of the working copy or if the Requirements from the download page are simply wrong?

          Comment


          • #6
            Hi there,

            Sorry to hear that, if you don't mind us asking what is it in the build environment that's not compatible? Just asking so we can replicate this for you and see what's going on. You'll be fine committing a 1.8 working copy to a 1.7 server, though from what you've said that's not the problem :/

            Cheers,

            Matt

            Comment


            • #7
              Incidentally, I've tried several times to download an older version of smartsvn from the website to downgrade back to a version that is compatible with a 1.7 working copy, and have not succeeded (the mail with the download link never arrives for older versions, but it does for the latest version). I am also not able to create a support account to book a ticket, as the validation mail never arrives (my email address is js@mcs.fm). So, I've basically given up on smartsvn at this point and gone back to tortoise.

              Comment


              • #8
                Hi,

                We've had a look and can't see any form records with that email address, though we've tested it with the same address (so if you've received emails that's why) and they've gone through fine.

                I'll drop you a PM with some links to the older version (7.6.3), not sure which OS it is you're using so we'll send all three, hope that helps.

                Cheers,

                Matt

                Comment


                • #9
                  I haven't received any mails, so they must be getting intercepted somewhere. Thanks for the links.

                  Comment


                  • #10
                    Originally posted by orbrey View Post
                    Hi there,

                    Sorry to hear that, if you don't mind us asking what is it in the build environment that's not compatible? Just asking so we can replicate this for you and see what's going on. You'll be fine committing a 1.8 working copy to a 1.7 server, though from what you've said that's not the problem :/

                    Cheers,

                    Matt
                    I understand that there would not be any problems using a 1.8 working copy with a 1.7 (or, as in our case, 1.6) server.
                    The problem is that we have build scripts within our source code which make use of subversion commands. That means that the working copy must be compatible with both the GUI version control client (in this case SmartSVN) and with the command line tools in use on our build systems.

                    Since we are currently standardised on using subversion 1.7 on our build systems this seems to mean that we cannot use SmartSVN 8.

                    For the time being I can continue to use SmartSVN 7 - my question was to confirm that my analysis was correct and also to query why the download page continues to state that "SmartSVN version 8 works with Subversion 1.6, 1.7 and 1.8 binaries."
                    From what you say SmartSVN 8 is not compatiable with the use of 1.6 or 1.7 binaries used on the same working copy.

                    Comment


                    • #11
                      Hi,

                      Your analysis is correct in that you can't use SmartSVN 8, though from what you've said that's not because you're standardised on using Subversion 1.7 (you'll be fine committing a 1.8 working copy to a server running 1.7 or 1.6, which is why the download page continues to state what it does) - it looks like it's the commands in the build scripts you mention that are the incompatibility in this case.

                      Nontheless I'm sorry that the latest version isn't working for you.

                      Cheers,

                      Matt

                      Comment

                      Working...
                      X