Announcement

Collapse
No announcement yet.

v1.7RC3: redirect cycle detected

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • v1.7RC3: redirect cycle detected

    Hi,

    I am using/testing v1.7 RC3 on CentOS 5.7 (WANdisco installer). I have created several repositories and I am able to checkout/update/commit using the file:// protocol. I can access the repositories via http in a browser (http://localhost/repo/projx) and browse through the folder structure but when I try to checkout using http I get the following error (after the authentication dialog):
    Redirect cycle detected for URL http://[ipaddress]/repo/projx

    My subversion.org looks like this:
    <Location /repo>
    DAV svn
    # SVNPath /svn/repo
    SVNParentPath /svn/repo
    AuthType Basic
    AuthName "Subversion repos"
    AuthUserFile /etc/svn-auth-conf
    Require valid-user
    </Location>

    Whats going wrong?

    Wybe Horsman

  • #2
    What client are you using? Can you include all of your apache config and the command line error output? Would also be worth looking in the apache access and error log.

    Comment


    • #3
      I use Tortoise 1.7 b2 on a Windows machine and the svn commandline tools on CentOS. Both give the same error message, so it's probably Apache related rather than subversion related. I'll digg into the Apache logs and get back with more info.

      Comment


      • #4
        problem solved: I removed the symbolic links to the repository root in /var/www (there was a symlink from /var/www/repo to /svn/repo which is the base folder for my repositories). After removing the symlinks and restarting the httpd service, all worked fine.

        Comment


        • #5
          Hello, I'm having the same problem. How do I remove the symbolic links? Please help me

          Comment


          • #6
            redirect cycle detected while accessing svn repository .

            hey, i have created a repository and created the user for it.
            But when i pasted the URL of repository in browser it asked for username and password. After entering the username and password it showed this error:

            Redirect cycle detected for URL http://localhost/svn/repos

            <Location /svn/repos>
            DAV svn
            SVNParentPath var/www/html/svn/repos

            AuthType Basic
            AuthName "Subversion repository"
            AuthUserFile /var/www/html/svn/repos/conf/passwd
            Require valid-user

            </Location>

            What is wrong in above configuration?

            Comment

            Working...
            X