Announcement

Collapse
No announcement yet.

Metadata file does not match checksum?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Metadata file does not match checksum?

    This might just be a newbie mistake here, but after adding the 1.7 repo to my /etc/yum.repos.d, when I do a "yum list subversion", expecting to see 1.7.0-3 listed, I get this error message:

    wandiscosvn17/primary | 4.2 kB 00:00
    http://opensource.wandisco.com/cento...rimary.xml.gz: [Errno -1] Metadata file does not match checksum
    Trying other mirror.
    Error: failure: repodata/primary.xml.gz from wandiscosvn17: [Errno 256] No more mirrors to try.

    This the exact same error that I saw when alpha2 was posted, but it went away after a day or so. I've tried a "yum clean all" in case I had some stale metadata, but that didn't solve anything. I got this current error after reverting to a clean VM image where subversion had never been installed. Prior to the revert, "yum list subversion" only showed 1.7.0-2 even though -3 had been posted.

    Any clue on what I might be doing wrong? Thanks.

    For the record, here's my complete list of steps:
    1. Install alpha1 without any problem
    2. After alpha2 comes out, uninstall alpha1, try to install alpha2 and get the error listed above.
    3. Wait a day or so and try again. It works.
    4. After alpha3 comes out, uninstall alpha2. Try to install alpha3, but only alpha2 is installed. "yum list subversion" shows only 1.7.0-2 even 1.7.0-3 is available here: http://opensource.wandisco.com/cento...l/RPMS/x86_64/
    5. Revert to clean image, re-add the 1.7 devel repo. Try to install alpha3, but get the error listed above.

    Joel Jirak

  • #2
    Appreciate that Joel, I've forwarded the details to the appropriate people.

    Comment


    • #3
      I've just downloaded the files and verified that the checksums match. I don't use a RPM system to verify the behaviour but I guess that something is causing you to use a stale version of primary.xml.gz. I suppose it could be yum itself or it could be a proxy between you and WANdisco. You can suggest that proxies refresh the file by sending "pragma:no-cache" http header, although the proxy may not honour the request:

      $ wget --no-cache http://opensource.wandisco.com/cento...primary.xml.gz

      The checksum of that file should be:

      $ sha1sum primary.xml.gz
      8411cd48f20318ab56b8a302ccb6ab4663780a2f primary.xml.gz

      There should be 7 lines that refer to 1.7.0-3

      $ zgrep -c 1.7.0-3 primary.xml.gz
      7

      Comment


      • #4
        I was able to install using yum this morning, so it looks like the stale HTTP cache is the most likely culprit. I'm sure that the metadata was up to date when I was getting the errors because I did manually download primary.xml.gz and saw references to 1.7.0-3. But wait, that means that my browser (going through an HTTP cache) saw something different than what yum saw. Yum and the browser were on separate systems, so maybe they're hitting different proxies?

        No matter. It's working now. And I will try the wget suggestion if I encounter this error again. Also, it looks like yum has an http_caching=none option I can try as well.

        Thanks to everyone for their help.

        Joel Jirak

        Comment


        • #5
          Good stuff Joel, glad it's working now.

          Comment


          • #6
            Wanted to record my final solution for posterity:

            When 1.7.0-4 was released, I got the same yum checksum error, and

            1. 'wget --no-cache http://opensource.wandisco.com/cento...primary.xml.gz' did NOT fix the error, even though the file downloaded was the correct version.

            2. 'http_caching=none' in my yum.conf file DID fix the error.

            Thanks.

            Joel Jirak

            Comment


            • #7
              Not able to solve

              Hi Joel,

              I am not able to solve this problem.can you please send me step by step to solve this problem on redhat linux

              Thanks in advance

              From
              Neeta

              Comment


              • #8
                Hi Neeta,

                Going by what Joel said, you need to edit your yum.conf file (/etc/yum.conf) and add the line
                Code:
                http_caching=none
                to it, that should get things working again.

                Please let us know how it goes.

                Comment

                Working...
                X