Announcement

Collapse
No announcement yet.

"Permission denied" for random files in .svn/

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • "Permission denied" for random files in .svn/

    hello community,

    I am having severe problems during checkout, update, cleanup, ... with svn 1.7.x on Scientific Linux 7 (Redhat Linux 7 derivate):

    svn: E000013: Can't open file '/mnt/NAS/users/USER/svn_checkouts/SDMZIP/.svn/pristine/12/1235ab0e69fb5eff488a3d5e5d6094833327234a.svn-base': Permission
    denied
    (the file path and the error message varies, but not the "Permission denied")

    When I check the file via ls -lh it usually works:

    $ ls -hl /mnt/NAS/users/USER/svn_checkouts/SDMZIP/src/test/utils/checkHandle.hpp
    -rw-r--r--. 1 fnatter fnatter 1,5K 24.Jul 12:20 /mnt/NAS/users/USER/svn_checkouts/SDMZIP/src/test/utils/checkHandle.hpp

    This occurs on several computers, with several users, I think only on NAS (nfs-)mounted shares, with two different svn servers (self-hosted, externally hosted).
    It often works when I do the operation on another computer that also mounts the same network share.
    I tried to disable SELinux, but still get the problem.

    I would appreciate any ideas!

    Many Thanks and Best Regards,
    Felix


  • #2
    Quick few things:
    1. SVN 1.7 is ANCIENT and unsupported and has not been supported for years. You need to update to something recent, like SVN 1.14 (or 1.10).
    2. This is almost certainly not an SVN issue but one due to the NAS itself.
    3. NFS is "not your friend". Regardless of how "easy" it first appears to be, I've spent decades fighting NFS to behave properly. There is sooo much wrong with it that entire essays have been written (and ignored).
    4. SELinux is not likely the problem. I guess it could be, but it's far less likely since with SELinux it either "works" or "does not work" 100% of the time.

    Things to check:
    A. Make sure that if multiple Linux clients are mounting the same NFS server's export that all of the clients are using the exact same UID/GID for the identical account names. This can require a significant amount of work on your part but if you don't do that then you're going to get exactly the error you're seeing.
    B. In general, do NOT access the same working copy from multiple NFS client machines at the same time (one at a time only).

    Comment

    Working...
    X