Announcement

Collapse
No announcement yet.

Loading mod_dav_svn - ap_log_perror

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Loading mod_dav_svn - ap_log_perror

    Hi..

    Hoping for some directions here on this error.. Been struggling with this for several months (I quit for a while then return) Today I upgraded to SVN 1.7.17 based on finding that I had to have SVN > 1.7.6 to use SVN in Apache 2.4.x.. I thought I had it wired today.. but nada...

    System
    CentOS 6
    Apache 2.4.9 - compiled from source
    SVN 1.7.17 updated from WANdisco repo via yum (was 1.7.4)

    Error: (summarized)

    "Cannot load modules/mod_dav_svn.so: .../modules/mod_dav_svn.so: undefined symbol: ap_log_perror"

    I then discovered that the mod_dav_svn.so was not getting created in my Apache compile (some how I thought that from way back when... brain cells long gone...) and was the OLD version.. duh...

    ./configure --prefix=/usr/local/apache
    --enable-setenvif
    --enable-ssl
    --enable-so
    --enable-rewrite=shared
    --enable-dav=shared
    --enable-dav-fs=shared

    Bad assumption obviously..

    So I installed mod_dav_svn.so from the WANdisco repo and updated both the mod_dav_svn.so and mod_authz_svn.so into the ../apache/modules directory..

    Same error...???

    I have to still be missing a brain cell here... and something still is a miss match... Hopefully I provided enough info, let me know what is missing.

    Thanks for any suggestions...

  • #2
    Might be a daft question (and apologies if so) but have you restarted httpd since the upgrades or (even better) rebooted? If so and it's still not working please post back and we'll see what we can do.

    Comment


    • #3
      Originally posted by orbrey View Post
      Might be a daft question (and apologies if so) but have you restarted httpd since the upgrades or (even better) rebooted? If so and it's still not working please post back and we'll see what we can do.
      Thanks for replying.. No not daft question, leave no stone unturned..

      Yes, in fact here is the process I used.. (I have backups of everything)

      --stop httpd
      --empty modules directory
      --do "make install" for new version of apache
      --confirm modules directory contents
      --copy mod_dav_svn.so and mod_authz_svn.so into the ../apache/modules directory.
      --review httpd.conf
      --start httpd

      I did not reboot because that takes about 10-15 each time.. (leased dedicated server at 1and1.com)

      Hope that will help..

      Comment


      • #4
        I guess if that's the case both modules are listed in your httpd.conf and/or (if it's separate) the subversion.conf file?

        Comment


        • #5
          Originally posted by orbrey View Post
          I guess if that's the case both modules are listed in your httpd.conf and/or (if it's separate) the subversion.conf file?
          Yes both are listed..

          I currently have Apache 2.2.x running with SVN 1.7.17 all working fine.. It is the exact same httpd.conf with the exact same settings in the exact same order..

          The error occurs when upgrading Apache to 2.4.9.. and following the above procedure..

          Comment


          • #6
            I've done some googling around this and it looks like there were some bugs with the mod_dav_svn - though it's tough to tell what it is that's causing this. Looking at the changelog for svn 1.7.17 (http://svn.apache.org/repos/asf/subv...1.7.17/CHANGES) it seems if you're using apache 2.4.5 or 2.4.6 the mod_dav_svn won't be built correctly and there are some blacklisted versions - which could explain what's happened re your mod_dav_svn not being built?

            Sorry I've not been able to offer a solution yet but I hope this sheds some light on what might be happening?

            Comment


            • #7
              Originally posted by orbrey View Post
              I've done some googling around this and it looks like there were some bugs with the mod_dav_svn - though it's tough to tell what it is that's causing this. Looking at the changelog for svn 1.7.17 ...........- which could explain what's happened re your mod_dav_svn not being built?
              Hmm... That suggest that maybe I need to run ./configure again... I did not run it AFTER I update this last svn version.. and then re compile..

              OK.. let me try that first and see if that does the trick...

              Thanks for the ideas.. I'll report back..

              Comment


              • #8
                I did some more Googling and since it has been so long since originally installed the original SVN on this server I had forgotten a number of details..

                Clearly mod_dav_svn is created during the compiling of Subversion..AGAINST a version of Apache. Therefore what version of Apache is your mod_dav_svn compiled against? Maybe if I can work on it from that angle..?? (note I have been trying to match it up with httpd 2.4.9, the latest release is 2.4.10)

                Thanks..

                Comment


                • #9
                  It'll have been the default version of apache that was installed with CentOS 6.5 I believe (on mine that's showing as 2.2.15), but you may have an easier time of it if you compile your own subversion against your own system with what's installed now?

                  Comment


                  • #10
                    Originally posted by orbrey View Post
                    It'll have been the default version of apache that was installed with CentOS 6.5 I believe (on mine that's showing as 2.2.15), but you may have an easier time of it if you compile your own subversion against your own system with what's installed now?
                    Thanks for following through on this.. I think you cleared up the issues for me.. The mod_dav_svn.so was compiled against 2.2 so it is not going to work IN a 2.4 environment.. I did not understand those implications until now. So... sadly I will have to go the long and torchered route of compiling Subverison against 2.4.x.

                    Thanks again.. much appreciated...

                    Comment

                    Working...
                    X