Announcement

Collapse
No announcement yet.

Getting SVN Directory Specific Permissions to Work

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Getting SVN Directory Specific Permissions to Work

    I've tried the instructions on this site: http://svnbook.red-bean.com/en/1.7/s...asedauthz.html

    And, well, they haven't worked for me.

    I get the Authorization Failed message from the Tortoise SVN browser.

    My Authz file looks like this:

    ============================================

    [/]
    Matt = rw
    Tom = rw
    Ben = rw
    Janet = rw

    [/Production]
    Assembler = r
    ============================================
    I've also tried
    [avc:/Production]
    ============================================
    And
    [/usr/local/svn/repos/avc:/Production]
    ============================================

    None of the above configurations for permissions gave me anything other than the simple "Authorization Failed" when trying to login as the Assembler. However, I can login as any of the other users, and can login as Assembler if I had Assembler to the [/] Root directory permissions.

    Please help, I'm baffled!
    Last edited by MattF; 02-14-2014, 09:32 PM.

  • #2
    Hi MattF,

    When you say the instructions "haven't worked" do you mean no one has access to your repository?

    Are you able to access your repository via http if you completely remove the AuthzSVNAccessFile directive from your sunberison.conf?

    It may be useful to see a sample of your Authz file to see what kind of rules you are using? Thanks

    Comment


    • #3
      I have updated the initial post with the contents of the Authz file.

      Comment


      • #4
        So the BIG question is if this is intentionally and how it is supposed to work, or is the intention of the Tortoise client that it always should correctly indicate if a file is out of sync using the corresponding icon overlay no matter if the file/folder is changed and committed by another client on the network ???


        ________________________
        www.solitairechamp.biz
        Last edited by vastonsmith; 12-04-2015, 12:15 PM.

        Comment

        Working...
        X