Announcement

Collapse
No announcement yet.

SVN not storing password

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • SVN not storing password

    Hi All,

    I am using Subversion server Apache :- 1.7.5 (r1336830) &
    SVN Apache Client :- svn, version 1.8.0 (r1490375) compiled Jun 24 2013, 00:45:10 on x86_64-redhat-linux-gnu.

    I am able to store the SVN Credentials before upgarding svn client (ran :- svn upgarde) after that i am not able to store the svn credentials. So, everytime it prompts for password.

    I have tried all these steps but no luck :-

    1) Deleted .subversion folder :- rm -rf ~/.subversion

    2) Modified servers file (~/.subversion/servers) :-
    [global]
    store-passwords = yes
    store-ssl-client-cert-pp = yes
    store-plaintext-passwords = yes
    store-ssl-client-cert-pp-plaintext = yes

    3)Modified config file (~/.subversion/config) :-
    [auth]
    store-passwords = yes
    store-auth-creds = yes


    Could anyone please help.... Its annoying to enter such log passwords in lower environments. How can i fix this problem ?

    Regards,
    msvr

  • #2
    Are you trying to use plaintext password storage, gnome keyring, kde wallet or gpg agent? Are you using svn+ssh?

    It's possible that your binary was built with plaintext password storage disabled. If you run 'svn --config-dir xx' to create a new config directory does xx/servers contain "# store-plaintext-passwords = no"? If the new file doesn't contain that line then plaintext password storage is disabled.

    Comment


    • #3
      I have enabled all the password related setting is the global configuration to store the credentials...There is no requirement to save my password in plan text for us...

      All, I am using was svn co from the linux command line as :- svn co https://scm.abcdef.com/svn/MFG/trunk

      Please find the default configurations in servers after deleting ~/.subversion directory and running the above command :-
      [global]
      #
      # Password / passphrase caching parameters:
      # store-passwords = no
      # store-ssl-client-cert-pp = no
      # store-plaintext-passwords = no
      # store-ssl-client-cert-pp-plaintext = no

      And also please find the default values in config file after deleting ~/.subversion directory and running the above command :-
      [auth]
      # store-passwords = no
      # store-auth-creds = no

      Now, How can i store my credentials in svn? What should i do ?

      Thanks,
      msvr

      Comment


      • #4
        Sorry , I haven't read all the configuration, After changing the following settings it started to store the credentials:-


        In ~/.subversion/config file :- (Changed as)

        ### Section for authentication and authorization customizations.
        [auth]
        ### Set password stores used by Subversion. They should be
        ### delimited by spaces or commas. The order of values determines
        ### the order in which password stores are used.
        ### Valid password stores:
        ### gnome-keyring (Unix-like systems)
        ### kwallet (Unix-like systems)
        ### gpg-agent (Unix-like systems)
        ### keychain (Mac OS X)
        ### windows-cryptoapi (Windows)
        password-stores = gpg-agent,gnome-keyring,kwallet
        ### To disable all password stores, use an empty list:
        password-stores = yes
        ###
        ### Set ssl-client-cert-file-prompt to 'yes' to cause the client
        ### to prompt for a path to a client cert file when the server
        ### requests a client cert but no client cert file is found in the
        ### expected place (see the 'ssl-client-cert-file' option in the
        ### 'servers' configuration file). Defaults to 'no'.
        ssl-client-cert-file-prompt = yes
        ###
        ### The rest of the [auth] section in this file has been deprecated.
        ### Both 'store-passwords' and 'store-auth-creds' can now be
        ### specified in the 'servers' file in your config directory
        ### and are documented there. Anything specified in this section
        ### is overridden by settings specified in the 'servers' file.
        store-passwords = yes
        store-auth-creds = yes

        ### Section for configuring external helper applications.

        In ~/.subversion/servers file :- (Changed as)

        [global]
        # http-proxy-exceptions = *.exception.com, www.internal-site.org
        # http-proxy-host = defaultproxy.whatever.com
        # http-proxy-port = 7000
        # http-proxy-username = defaultusername
        # http-proxy-password = defaultpassword
        # http-compression = no
        # No http-timeout, so just use the builtin default.
        # No neon-debug-mask, so neon debugging is disabled.
        # ssl-authority-files = /path/to/CAcert.pem;/path/to/CAcert2.pem
        #
        # Password / passphrase caching parameters:
        store-passwords = yes
        store-ssl-client-cert-pp = yes
        # store-plaintext-passwords = no
        # store-ssl-client-cert-pp-plaintext = no

        Thanks,
        msvr

        Comment


        • #5
          And also please find the default values in config file after deleting.subversion directory and running the above command :-

          Comment

          Working...
          X