Announcement

Collapse
No announcement yet.

Subversion Binaries for OSX 10.10 Yosemite now available

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Subversion Binaries for OSX 10.10 Yosemite now available

    Hi all,

    We've just released Subversion binaries for the latest update of Mac OSX 10.10, Yosemite. You can find them in the usual place: https://www.wandisco.com/subversion-products

    As ever if you've any questions or feedback please give us a shout, cheers.

  • #2
    Matt,

    I downloaded the package and it was rejected by the installer saying the signature is bad.
    So I unpackaged it from the command line and manually installed it.
    Apache complains:
    Cannot load /opt/subversion/lib/svn-apache/mod_dav_svn.so into server: dlopen(/opt/subversion/lib/svn-apache/mod_dav_svn.so, 10): Symbol not found: _dav_do_find_liveprop\n Referenced from: /opt/subversion/lib/svn-apache/mod_dav_svn.so\n Expected in: flat namespace\n in /opt/subversion/lib/svn-apache/mod_dav_svn.so

    ?

    Comment


    • #3
      Oops! Turns out it was the Apache configuration!

      Make sure to activate (in this order):
      LoadModule dav_module libexec/apache2/mod_dav.so
      LoadModule dav_fs_module libexec/apache2/mod_dav_fs.so
      LoadModule dav_svn_module /opt/subversion/lib/svn-apache/mod_dav_svn.so
      LoadModule authz_svn_module /opt/subversion/lib/svn-apache/mod_authz_svn.so

      cheers!

      Comment


      • #4
        Ah, glad you got it sorted, thanks for letting us know

        Comment


        • #5
          Originally posted by orbrey View Post
          Hi all,

          We've just released Subversion binaries for the latest update of Mac OSX 10.10, Yosemite. You can find them in the usual place: https://www.wandisco.com/subversion-products

          As ever if you've any questions or feedback please give us a shout, cheers.
          I don't see them. Were they pulled?

          The installer for the 10.9 build doesn't let you actually install; it just hangs at asking whether to install for all users or just one.

          -a

          Comment


          • #6
            Apologies, yes they're down at the moment while that bug is fixed. I'll update this thread as soon as we have more information (or as soon as they're back).

            Comment


            • #7
              thanks for letting us know

              Comment

              Working...
              X